Make linuxbrew work on Fedora 20

When installed, linuxbrew looks for versioned gcc binaries/symlinks e.g. gcc-4.8. Fedora 20 comes with gcc 4.8 which is new enough for linuxbrew, but there is no versioned symlink. If you try to 'brew install' it will complain about there being no suitable compiler on the system. To fix:

sudo ln -s /usr/bin/gcc /usr/bin/gcc-4.8

Linuxbrew is great on older systems like RHEL 6.x which I use in work. It's indispensible there to get up-to-date software installed to a home directory quickly and esaibly. Less necessary on more up to date systems with newish packages via yum or apt-get, but having it on Fedora 20 means I can do the same thing in work, on my mac, or on my Linux machine.

Comments

Comments powered by Disqus